Сохраните файл конфигурации в nvram

Сохраните файл конфигурации в nvram

Шпаргалка для себя и для студентов

Установка пароля для консоли
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login

Установка пароля для telnet
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login

Удаление консольного пароля
router(config)#line console 0
router(config-line)#no login
router(config-line)#no password

Удаление пароля Secret
router(config)#no enable secret

Проверка параметра Register
router>enable
router#show version

Задание адреса-маски и административное включение интерфейса
R1(config)#interface Serial0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0

Административное выключение интерфейса маршрутизатора
router(config)#int s0/0
router(config-if)#shutdown

Включение интерфейса Serial
router#configure terminal
router(config)#interface s0/0
router(config-if)#no shutdown
Установка тактовой частоты для интерфейса Serial
router(config-if)#clock rate 64000

Проверка интерфейса Serial
router(config)#show interfaces s0/0

Добавить статическую запись в таблицу маршрутизации
Router(config)#ip route 10.10.10.0 255.255.255.0

Посмотреть таблицу маршрутизации
R1#show ip route

Посмотреть интерфейсы
R1#show interfaces

Посмотреть интерфейсы и их статистику в табличном виде
R1#show ip interface brief

Посмотреть соседей устройства:
Router#show cdp neighbors
Router#show cdp neighbors detail

Глобальное выключение CDP (cisco discovery protocol):
Router(config)#no cdp run
Выключение CDP (cisco discovery protocol) на интерфейсе:
Router(config-if)#no cdp enable

Статус DTE/DCE
router#show controllers s0/0

Сохранение конфигурации
router#copy running-config startup-config

Загрузка файла (например IOS) с TFTP сервера

R#copy tftp flash:

Резервное копирование Startup конфига на TFTP
router#copy startup-config tftp

Сохранение Running конфига
router#write memory
router#copy run st

Удаление конфигурации NVRAM
router#write erase

Проверка конфигурации NVRAM
router#show startup-config

Посмотреть таблицу MAC адресов свитча
show mac-address-table

Статически прописать MAC адрес в таблицу адресов свитча
#mac-address-table static MAC address vlan interface interface-id command

Создать VLAN
S1(config)#vlan 20
S1(config-vlan)#name students

Создаем интерфейс для управления VLAN
S1(config)#interface vlan 20
S1(config-if)#ip address 10.2.2.1 255.255.255.0
S1(config-if)#no shutdown

Назначить порт для доступа к VLAN
S1(config)#interface fa0/18
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 20

Назначить порт для транка Cisco Dynamic Trunking protocol
S1(config)#interface fa0/18
или S1(config-if)#switchport mode trunk
ли S1(config-if)#switchport mode dynamic auto
или S1(config-if)#switchport mode dynamic desirable
или S1(config-if)#switchport mode nonegotiate

какие vlan пропускать через trunk
S1(config-if)#switchport trunk allowed vlan 18 (можно указывать диапазоны или all)

Переключиться обратно из trunk в режим доступа
S1(config-if)#no switchport trunk allowed vlan
S1(config-if)#no switchport trunk native vlan
S1(config-if)#switchport mode access

Читайте также:  Градация оценок по 100 бальной системе

Разрешить трафик местного (native) VLAN через порт транка
S1(config)#interface fa0/18
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 18
S1#show interfaces fa0/18 switchport

Посмотреть статистику VLAN
или show vlan brief
или show vlan id 20
или show vlan name students
или show vlan summary

Посмотреть статистику портов свитча
show interfaces vlan 20
show interfaces fa0/18 switchport

Назначить шлюз по умолчанию
S1(config)#ip default gateway 1.2.3.4

Включить протокол динамической маршрутизации
R1(config)#router протокол (rip, eigrp и т.д.)
R1(config-router)#network network_number [wildcard_mask]
R1(config-if)#bandwidth 64

R1(config-router)#passive-interface s 0/0/0 Выключить динамическую маршрутизацию на интерфейсе
или
R1(config-router)#passive-interface default Выключить динамическую маршрутизацию на всех интерфейсах
а потом на некоторых включить:
R1(config-router)#no passive-interface s 0/0/0

Как мы обсуждали ранее, изменение рабочей конфигурации влияет на работу устройства сразу же.

После произведения изменений в конфигурации Вы можете:

Сделать измененную конфигурацию новой конфигурацией запуска.

Возвратить устройство к его исходной конфигурации.

Удалить всю конфигурацию из устройства.

Как сделать Измененную Конфигурацию Новой Конфигурацией Запуска

Помните, поскольку рабочая конфигурация хранится в RAM, она является временной — пока устройство Cisco работает (включено). Если питание маршрутизатора будет отключено или если маршрутизатор будет перезапущен, то все изменения конфигурации будут потеряны, если они не были сохранены.

Сохранение рабочей конфигурации в конфигурационном файле запуска в NVRAM сохранит изменения в новой конфигурации запуска.

Перед сохранением изменений используйте соответствующие команды show, чтобы проверить работу устройства. Как показано на рисунке, можно использовать команду show running-config , чтобы просмотреть рабочий конфигурационный файл.

Когда изменения проверены на корректность, используйте команду copy running-config startup-config в подсказке привилегированного режима EXEC. Следующий пример показывает команду:

Switch#copy running-config startup-config

После того, как команда выполнена, рабочий конфигурационный файл заменяет конфигурационный файл запуска.

Возврат Устройства к Его Исходной Конфигурации

Если изменения, произведенные в рабочей конфигурации, не привели к желаемому эффекту, можно восстановить устройство к его предыдущей конфигурации. В предположении, что мы не перезаписали конфигурацию запуска сделанными изменениями, мы можем заменить рабочую конфигурацию конфигурацией запуска. Проще всего это сделать, перезапустив устройство, используя команду reload в подсказке привилегированного режима EXEC.

Читайте также:  Как разлочить минифон мегафон

Инициируя перезагрузку, IOS обнаружит, что у рабочей конфигурации есть изменения, которые не были сохранены в конфигурации запуска. Будет предложено сохранить произведенные изменения. Чтобы отклонить изменения, введите n или no .

Появится дополнительная подсказка, предлагающая подтвердить перезагрузку. Чтобы подтвердить, нажмите клавишу Enter. Нажатие любой другой клавиши прервет процесс.

Компоненты коммутатора и маршрутизатора. Их назначение

Сегодня мы изучим операционную систему Cisco IOS (Internetwork Operating System).

Маршрутизаторы/Коммутаторы состоят из следующих компонентов памяти:

ROM — Read Only Memory (ПЗУ — Постоянное Запоминающее Устройство).

Хранит 4 системные утилиты:

  • POST (Power On Self Test) — производит самодиагностику системы при подаче питания.
  • Bootstrap — загрузчик операционной системы
  • ROMMON (иначе ROM Monitor) — специальная программа IOS. Используется для диагностики системы, а также для восстановления пароля.
  • Mini IOS (RXBOOT режим) — урезанная версия IOS. Загружается в случае, если не удалось загрузить полную версию IOS.

RAM — Random Access Memory (ОЗУ — Оперативное Запоминающее Устройство).

  • Таблицу маршрутизации — только у маршрутизаторов
  • ARP и CDP таблицы (об этом позже)
  • Распакованную IOS
  • Файл конфигурации
  • Таблицу MAC адресов (CAM- table) — только у коммутаторов

NVRAM — Non Volatile Random Access Memory (Перезаписываемое Запоминающее Устройство). Хранит файл конфигурации (startup-config).

FLASH (Перезаписываемое Запоминающее Устройство) — хранит IOS.

Порядок загрузки ОС маршрутизатора

Весь процесс проходит через следующие стадии:

  1. Включение питания
  2. Диагностика системы — POST
  3. Проверка регистра загрузки (смотрит откуда загружать IOS)
  4. Поиск IOS в FLASH памяти и загрузка ее в RAM
  5. В случае сбоя загрузки IOS из FLASH происходит поиск ОС на сервере TFTP
  6. Если IOS не найдена на сервере TFTP, то система ищет укороченную версию IOS в ROM
  7. Если и в ROM IOS не найдена то система переходит в режим ROMMON для диагностики
  8. Как только IOS будет загружена в RAM система начнет поиск файла конфигурации в NVRAM с последующей загрузкой его в RAM
  9. Если файл не найден, то система перейдет в режим SETUP (первоначальной загрузки).
Читайте также:  Meizu mx6 pro 6

Порядок загрузки проиллюстрирован ниже:

Значения параметров регистра

Значение регистра указывает загрузчику (Bootstrap) откуда загружать IOS.

По умолчанию его значение равно 0х2102 (шестнадцатеричное число).

Возможны следующие значения:

  • 0х2100 — всегда загружать режим ROMMON.
  • 0х2101 — всегда загружать режим RXBOOT.
  • 0х2102 — 0х210F — всегда загружать первый IOS в FLASH (в памяти могут храниться несколько IOS).
  • 0х2142 — игнорирует загрузку файла конфигурации startup-config. Служит для восстановления пароля.

С помощью нижеприведенных команд можно узнать подробные сведения о системе:

Router# show version

Команда показывает версию аппаратной платформы, текущую ОС, емкость памяти, а также значение регистрационного файла:

Список файлов в памяти FLASH:

Router# dir flash:

Список файлов в памяти NVRAM:

Router# dir nvram:

Проводится только через консольный порт.

В маршрутизаторе все пароли находятся в конфигурационном файле startup-config. Поэтому необходимо загрузить систему без этого файла и поменять пароль.

Для этого последовательно выполним следующие действия:

1. Перезагрузить маршрутизатор и в течении первых 20с прервать загрузку нажатием на CTRL+C или CTRL+Break. Система перейдет в режим Rommon.

2. Поменять параметр регистра на 0х2142:

rommon> confreg 0x2142

3. Перезагрузить маршрутизатор

4. Проигнорировать режим первоначальной загрузки и ввести:

router# copy startup-config running-config

5. Теперь можно установить новый пароль

6. Вернуть параметр регистра на 0х2102:

router(config)# config-register 0x2102

Для коммутатора процедура немного другая:

1. Отключить питание. Нажать и удерживать кнопку Mode. Затем включить питание коммутатора. Кнопку удерживать, пока не перестанет мигать светодиод SYST:

3. Конфигурационный файл condif.text хранится в памяти Flash. Посмотрим содержимое памяти:

switch: dir flash:

4. Конфигурационный файл config.text переименуем в config.bak:

switch: rename flash:/config.text flash:/config.bak

5. Теперь перезагрузим коммутатор:

6. Коммутатор после перезагрузки не содержит конфигурацию, так как не нашел файл config.text.

7. Копируем сохраненную конфигурацию в ОЗУ:

switch# copy flash:/config.bak running-config

Теперь можно менять пароли. Не забудь сохранить конфигурацию.

Ссылка на основную публикацию
Сканер ricoh sp 220snw
Компания Ricoh — далеко не новичок на рынке печатающих устройств. Это глобальная корпорация со штаб-квартирой в Токио и представительствами во...
При каком альфа векторы компланарны
Единого обозначения компланарность не имеет. Свойства компланарности Пусть — векторы пространства . Тогда верны следующие утверждения: Если хотя бы один...
При каком значении m прямая параллельна плоскости
Точка C(—3, 4,1) найдена. 6. Написать уравнение плоскости, проходящей через точки M1(1, —2, 1), M2(4, 2, 3) и параллельной вектору...
Сколько дают на ютубе за 1000 просмотров
Многих пользователей YouTube, а также начинающих видеоблогеров справедливо интересует вопрос: «А сколько YouTube платит за тысячу или миллион просмотров?» Если...
Adblock detector